Benvenuti in Spybot - Search & Destroy

SpyBot - Search & Destroy
Freeware, © 2000-2002 Patrick Michael Kolla

SpyBot - Search & Destroy ricerca nel tuo PC diversi tipi di minacce provenienti da Internet - inclusi spyware and adware, keyloggers e tracce d'uso dei programmi (per esempio l'elenco delle pagine visitate che il browser memorizza). Spybot-S&D è in grado di correggere anche diversi problemi di sistema.

Spybot-S&D è dotato anche di alcuni strumenti di utilità, come il Tritatutto di sicurezza.

Licenza d'uso
Perchè freeware? Per una ragione molto semplice. Cosa ottieni vendendo un programma? Una sfilza di uni e di zeri, tutto qui. Se i programmi fossero venduti come oggetti artistici potrei capirlo.
Ma se lo scopo principale è guadagnare soldi - tramite diritti o pubblicità - non mi trovate d'accordo!
Ed è per tali motivi che questo programma è gratuito. Però se ti è piaciuto e ti sono stato d'aiuto, ti chiedo solo una cosa: una preghiera per me a nostro Signore e l'augurio di un po' di fortuna.

Requisiti Software e Hardware
Ovviamente hai bisogno di una piattaforma Windows a 32bit, come Windows 9x, ME, NT, 2000 o XP. Sono richiesti anche 2 Megabyte di spazio libero sul disco rigido.

Utilizzo
Avvia il programma con un doppio clic sul file SpybotSD.exe che trovi nella cartella in cui hai estratto l'archivio. Al primo utilizzo di Spybot-Search&Destroy ti verrà chiesto se vuoi creare un'icona sul desktop e/o una voce nel menù d'avvio.

Dopo queste operazioni sarai all'interno del programma!
Al primo utilizzo verrà visualizzata la sezione Impostazioni, che puoi personalizzare secondo le tue esigenze.

Se hai bisogno di ulteriori informazioni leggi il paragrafo relativo alla scansione.


Info sui Bot

In questa sezione puoi reperire maggiori informazioni riguardo i problemi che Spybot-S&D riesce ad individuare. Se sei giunto qui dalla pagina con l'elenco dei risultati, il problema di cui vuoi avere notizie potrebbe essere già selezionato, altrimenti puoi utilizzare il menu a discesa per selezionarne uno.

L'informazione visualizzata contiene soltanto gli URL, ma siccome alcuni di questi possono avviare direttamente un download (tramite controlli ActiveX), il doppio clic standard è stato disattivato. Invece, effettua un clic con il tasto destro sull'indirizzo indicato e seleziona il sito che desideri, ma solo sei sei certo che il tuo browser è configurato in maniera sicura.

Puoi anche escludere un prodotto software da ogni ulteriore futura ricerca utilizzando la casella di controllo "Escludi dalle ricerche", in alto nella pagina (ottieni la stessa cosa selezionando i singoli prodotti nella sezione Liste di esclusione).

Puoi reperire informazioni sul Prodotto (Bot) scegliendo Info sui Bot nella sezione Informazioni & Licenza tramite la barra degli strumenti posta a sinistra.


Lo spyware

Cos'è lo spyware? In parole semplici lo spyware è software che trasmette informazioni personali dal nostro computer a qualche posto su internet senza la tua autorizzazione.

Tipicamente lo spyware non è il software che installi direttamente, ma piccoli moduli aggiunti che non sempre puoi disabilitare durante l'installazione stessa. In molti casi la licenza d'uso del programma contiene da qualche parte poche righe che informano riguardo la riservatezza dei dati, ma è tipico di numerosi utenti non leggere completamente il contratto di licenza e non sapranno mai di essersi beccati uno spyware nel loro sistema.

Un po' meno minaccioso è il cosiddetto adware. L'adware è simile allo spyware, ma non trasmette informazioni personali o, almeno, il beneficiario promette di non venderle. Tipico dell'adware è invece il raccogliere dati aggregati sulle abitudini.

L'adware spesso è anche un effetto secondario dello spyware, poichè entrambi hanno un unico scopo: inviarti materiale pubblicitario tagliato su misura per te.

I cookie spia rappresentano un'altra specie che rientra nella categoria spyware. I cookie sono usati un po' dappertutto su Internet in situazioni più o meno utili. Spesso le compagnie pubblicitarie collocano i cookie ogniqualvolta il tuo browser visualizza un loro banner. In questo caso e se il cookie contiene un identificativo (GUID), la società raccoglie notizie su ogni sito da te visitato che contiene suoi annunci pubblicitari.


Il registro di sistema

Il registro di Windows contiene molte informazioni. La sua integrità può essere controllata con programmi commerciali di qualità come Symantec™ System Works. Ci sono tuttavia piccole omissioni da parte di questi programmi. Qui di seguito sono riportate le cose che SpyBot-S&D è in grado di rilevare:

  • File della guida persi: il registro di sistema contiene informazioni sulla posizione di alcuni file della guida. Se tali informazioni puntano a cartelle sbagliate, SpyBot-S&D te lo dice e ti consente di correggerle.

  • DLL condivise perse: il registro di sistema contiene la lista delle librerie a collegamento dinamico (DLL), quella della loro posizione e di quanti programmi le utilizzano. SpyBot-S&D controlla tutte le loro posizioni e permette di modificarle se non sono corrette.

  • Percorsi delle applicazioni: alcune applicazioni (spesso quelle che utilizzano estensioni di file) sono inserite nel registro di sistema. Se puntano ad un file di programma non più esistente, SpyBot-S&D è in grado di modificare il loro percorso o di cancellarne la voce di registro relativa.

  • Informazioni di disinstallazione errate: ogni programma che possiede una propria routine di disinstallazione inserisce alcune informazioni al riguardo nel registro di sistema. Se tali dati sono errati, per esempio perchè il programma di disinstallazione era collocato in una cartella temporanea (ci sono diversi programmi che si comportano stupidamente!), SpyBot-S&D te lo dice (e ti permetterà di modificarli nelle versioni future).

  • Collegamenti al desktop interrotti: se uno dei collegamenti del tuo desktop si riferisce ad un file non più esistente, Spybot-S&D te lo dirà e ti consentirà o di associare il collegamento ad un altro file o di cancellarlo.

Attenzione: Sii consapevole che le modifiche a tutte queste voci possono compromettere il sistema! Se non sei certo di quando un'impostazione rappresenta davvero un problema, meglio lasciarla così com'è!
Specialmente Microsoft Office™ inserisce nel registro di sistema alcune voci che puntano a cartelle errate e ad alcuni file della guida inesistenti. Le prime vanno corrette, ma le chiamate a file della guida non valide (in MOffice) non dovrebbero essere eliminate poichè potrebbero puntare correttamente a file installabili successivamente sulla base della funzione di Office "Installa al primo utilizzo".


Le tracce d'uso dei programmi

Le tracce d'uso dei programmi sono le tue impronte digitali sul sistema. Ogni volta che visiti una pagina web con il tuo browser, o semplicemente apri un file qualsiasi, le informazioni relative sono conservate nei profondi meandri di Windows. In molti casi questo può rivelarsi molto utile: se ad esempio vuoi riaprire velocemente un file lo puoi selezionare dalla lista dei Dati Recenti, dalla Cronologia di Internet, ecc., invece di ridigitare l'intero nome del file o ricercarne nuovamente il percorso o il sito.

Ma in certi casi potresti voler nascondere agli altri la tua attività, poichè spyware e attacchi da Internet potrebbero utilizzare quelle informazioni. Spybot-Search&Destroy è in grado di rimuovere dal tuo sistema molte delle più importanti e più comuni tracce d'uso.


Impostare le opzioni di base

Tutte le impostazioni più importanti sono elencate in questa sezione secondo una struttura ad albero. La descrizione che segue è ordinata secondo le categorie principali di tale struttura.

Puoi raggiungere queste regolazioni scegliendo Impostazioni nell'omonima sezione Impostazioni tramite la barra degli strumenti sulla sinistra.

Installazione
Questa categoria ti consente di aggiungere/rimuovere l'icona sul desktop e/o quella nel menù di avvio.

Impostazioni di Spybot-S&D
Le opzioni qui contenute si spiegano da sole.

Automazione
Spybot-S&D possiede due tipi di impostazioni di automazione: all'avvio del sistema e all'avvio del programma. Da qui puoi scegliere se avviare il programma al caricamento di Windows, controllare automaticamente gli aggiornamenti disponibili, far partire la scansione con un certo ritardo prestabilito quando si avvia il sistema o finchè altri programmi in esecuzione non vengano chiusi.

Impostazioni del file di rapporto
Spybot-S&D è in grado di registrare su file di testo i dettagli di ogni singola scansione. Da qui puoi scegliere se farlo o meno, se aggiungere la data e l'ora al nome del file generato oppure se accodare dati ad un file di rapporto esistente o sovrascriverlo.

Aspetto
Puoi cambiare qualche dettaglio nell'aspetto di Spybot-S&D. Prova le opzioni e guarda quale look ti piace di più.

Rapporto bugs
Se non sei sicuro riguardo qualche problema, puoi inviare un rapporto sui difetti del programma a PepiMK Software. Questo gruppo di opzioni serve a configurare l'invio dei dati. Nel rapporto dovresti per lo meno inserire le informazioni di sistema e i risultati della scansione (puoi vederne un'anteprima prima dell'inoltro). In aggiunta, se vuoi ricevere una copia dell'e-mail che invierai a PepiMK Software, puoi attivare 'Invia una copia del rapporto a me stesso' (per farlo devi cambiare l'indirizzo del server SMTP – vedi la guida relativa al Rapporto bugs).

Impostazioni avanzate
Sono consigliate ad utenti esperti. Permettono di usare al massimo le funzioni di SpyBot-S&D.


Scegliere la lingua d'interfaccia

Spybot-S&D utilizza linguaggi inclusi in file esterni cosicchè chiunque può scrivere il modulo per la propria lingua. Se vuoi cimentarti, per favore contatta PepiMK Software per ottenere supporto tecnico – non verrai pagato per questo, ma avrai fama imperitura ;)

Puoi raggiungere le impostazioni di lingua scegliendo Lingua nella sezione Impostazioni tramite la barra degli strumenti sulla sinistra.

Tutte le lingue disponibili sono visualizzate nell'elenco in maniera predefinita, ma se vuoi rimuoverne qualcuna (e successivamente reincluderla) puoi utilizzare il menu contestuale (tasto destro) dell'elenco.


Scegliere cosa controllare (Moduli di ricerca)

Per poter essere più flessibile, Spybot-S&D utilizza il concetto dei moduli di ricerca. Ogni modulo consiste in un file contenente la descrizione (l'impronta) di numerosi problemi che Spybot-S&D può identificare e correggere.

Puoi raggiungere queste impostazioni scegliendo Moduli di ricerca nella sezione Impostazioni tramite la barra degli strumenti sulla sinistra.

Questi file sono suddivisi in categorie, cosicchè puoi selezionare qui i tipi di problemi che vuoi individuare durante il controllo.

Le categorie base sono spyware-adware, problemi di sistema e tracce d'uso dei programmi. Per ognuna di queste categorie da qui puoi vedere quali sono i moduli relativi con una breve descrizione sulla loro funzione ed il numero di file, voci di registro e cartelle che verranno controllate.

Puoi scegliere cosa includere nelle ricerche attivando le caselle di controllo davanti alle singole voci (la prima dell'elenco non è disattivabile).

Se nell'elenco individui un nome in corsivo significa che quel modulo non è stato originato da PepiMK Software. Poichè i moduli sono pubblici, chiunque può scrivere un file del genere. Tieni comunque presente che i moduli possono arrecare gravi danni al sistema, per cui PepiMK Software non può dare garanzie sull'uso di moduli di terze parti. In ogni caso, se SpyBot-S&D individuerà file non firmati da PepiMK Software, ti chiederà se sei veramente certo di volerne fare uso.


Scegliere cosa non verificare (liste di esclusione)

Scegliere cosa NON controllare (Liste di esclusione)

Puoi raggiungere le impostazioni di esclusione scegliendo una categoria nella sezione Liste di esclusione tramite la barra degli strumenti sulla sinistra.

Attualmente ci sono quattro differenti sezioni di oggetti che possono essere esclusi dal controllo:

Prodotti
Questa sezione comprende tutti i prodotti definiti nei moduli di ricerca. Se vuoi escludere o riammettere una determinata voce attiva o disattiva la casella di controllo davanti al nome selezionato.

Cookies
I Cookies sono piccoli file che tengono traccia di una qualche attività sul web, ma potresti volerne mantenere alcuni di particolare utilizzo. Questa sezione mostra l'elenco di tutti i cookies correntemente presenti nel tuo sistema, permettendoti di escluderli da ulteriori ricerche.
(Attualmente soltanto i cookies scaricati da Internet Explorer e Netscape Navigator sono supportati – quelli di Opera possono soltanto essere rimossi).

Estensioni
Questa sezione è simile alla finestra di dialogo 'Apri file' di Windows. In essa vengono archiviati elenchi di file aperti (e salvati), divisi per estensione. Se, ad esempio, non vuoi rimuovere mai i file di Microsoft Word, è sufficiente selezionare l'estensione .doc per escluderli dai controlli.

Esclusioni singole
Se non desideri escludere totalmente un prodotto, ma soltanto un singolo file o voce di registro di esso, puoi selezionare quel file o quella voce dall'elenco dei risultati. Questi rimarranno elencati qui e puoi rimuoverli nuovamente dalla lista di esclusione in qualsiasi momento.

Tutte le liste delle quattro sezioni hanno un menù contestuale (tasto destro del mouse) con opzioni avanzate.


Configurare le cartelle di download

Alcuni dei problemi analizzati da Spybot-S&D possono essere inclusi nei file di installazione di vari programmi. Questi file, che l'utente scarica esplicitamente dal web, possono essere verificati soltanto se le cartelle che li contengono risultano inserite in questo elenco.

Puoi raggiungere le impostazioni delle cartelle di download scegliendo Cartelle nella sezione Impostazioni tramite la barra degli strumenti posta sulla sinistra.

Per aggiungere o rimuovere le cartelle dalla lista puoi trascinarle qui direttamente da una finestra di Windows Explorer (Esplora Risorse) oppure puoi usare il menu di contesto (o di popup) attivabile con il tasto destro.


Scegliere un'interfaccia

Spybot-Search&Destroy utilizza il concetto di interfaccia base per modificare le scelte cromatiche del programma secondo le esigenze o i gusti personali.

Puoi cambiare queste impostazioni scegliendo Interfacce nella sezione Impostazioni tramite la barra degli strumenti sulla sinistra.

Questa sezione contiene un elenco di interfacce disponibili. Basta selezionarne una per averne un'anteprima. L'anteprima (molto semplicemente) verrà visualizzata nella parte sinistra della finestra con alcune informazioni al di sotto dell'elenco e con il relativo logo ancora più sotto.

Se ti piace l'interfaccia scelta, premi il pulsante Applica.


Scansione del sistema

Una volta avviato Spybot-Search&Destroy, puoi procedere immediatamente con la scansione.

Dopo l'avvio, il programma mostra direttamente la pagina della scansione. Se così non fosse, seleziona Search & Destroy nella sezione Spybot-S&D tramite la barra degli strumenti sulla sinistra.

Questa schermata contiene una barra con le opzioni principali (la barra è spostabile a tuo piacimento nella parte superiore o inferiore della pagina). Iniziamo il controllo: premi il pulsante Avvia la scansione.

Puoi seguire lo stato di avanzamento della scansione dalla barra in fondo alla finestra (sulla sua destra viene visualizzato il tempo rimanente stimato) e interromperlo in ogni momento premendo il pulsante Interrompi la scansione che appare dopo l'avvio della stessa (questo pulsante sparisce nuovamente al temine del controllo).

Se la scansione ha individuato qualcosa verrà generata una lista. Ci sono tre tipi base di risultati:

  • Le voci in rosso indicano problemi di spyware che dovrebbero essere corretti per evitare inconvenienti alla sicurezza del sistema e/o alla privacy. Questo è l'unico tipo di problema individuato che ti viene proposto già preselezionato per poter essere corretto.

  • Le voci in nero indicano inconvenienti al registro interno di sistema. Se non ne comprendi appieno il significato è consigliabile che tu ne stia alla larga e che consulti il forum del supporto tecnico.

  • Le voci in verde indicano tracce d'uso di programmi. Non aver timore di rimuoverle.

Per molti dei problemi sono disponibili maggiori informazioni. Se evidenzi una voce dell'elenco degli inconvenienti riscontrati, in molti casi, si attiva il pulsante Descrive il prodotto selezionato. Premilo per documentarti (off-line) sul tipo di minaccia che hai incontrato.

Al termine della scansione, puoi procedere con il selezionare i problemi che vuoi correggere, attivando la casella di controllo davanti alle singole voci oppure utilizzando il pulsante Seleziona tutto. Sono disponibili più tipi di selezione se dai un'occhiata al menu contestuale (clic con il tasto destro su una voce qualsiasi). Il menù di contesto ti permette anche di escludere singoli problemi o interi prodotti software da ogni futura ricerca (puoi sempre includerli nuovamente rimuovendoli dalla sezione Liste di esclusione nella quale vengono inseriti).

Dopo esserti accertato di aver selezionato soltanto le voci che vuoi rimuovere dal computer, premi il pulsante Corregge i problemi selezionati. Puoi seguire lo stato di avanzamento del processo di correzione dalla barra situata nel margine inferiore della finestra.

Se un problema non può essere corretto al momento (per esempio perchè un processo è in esecuzione e non può essere terminato), Spybot-S&D si offre per rieseguire automaticamente un'ulteriore scansione al successivo avvio del sistema, cosicchè puoi nuovamente selezionare e, se possibile, correggere l'inconveniente.

Se ti accorgi in qualsiasi momento di aver rimosso più voci di quante ne intendevi, puoi sempre reintegrarle dalla sezione Ripristina.

Puoi affinare le tue ricerche selezionando moduli di ricerca speciali e modificando alcune impostazioni.


Ripristino

Questa funzione è raggiungibile scegliendo Ripristina dalla sezione principale Spybot-S&D tramite la barra degli strumenti sulla sinistra.

Questa pagina comprende anche una barra mobile simile a quella della sezione Search & Destroy.

Se precedentemente hai corretto qualche problema di spyware o di registro, questa lista lo visualizzerà. Da qui puoi selezionare uno o più problemi (tieni presente anche il menu contestuale per funzioni di selezione aggiuntive) e ripristinarli oppure eliminare definitivamente le voci dal sistema.


Aggiornamenti

Per evitare pesanti download e per maggiore flessibilità, la maggior parte delle informazioni di controllo di SpyBot-S&D sono contenute in moduli separati.

I moduli, ma anche i file della guida, i linguaggi, le descrizioni dei prodotti, ecc., possono essere aggiornati utilizzando l'apposita funzione integrata nel programma.

Naturalmente per eseguire gli aggiornamenti è necessaria una connessione ad Internet attiva.

Puoi utilizzare questa funzione scegliendo Aggiornamenti nella sezione Su Internet tramite la barra degli strumenti sulla sinistra.

Fatto ciò, premi il pulsante Cerca nuovi aggiornamenti. Quest'azione comporterà un confronto dei file già installati sul sistema e visualizzerà un elenco di aggiornamenti disponibili dal server di PepiMK Software.
I nuovi file visualizzati nell'elenco possono essere selezionati singolarmente e quelli non necessari (ad esempio linguaggi stranieri, file della guida in lingua straniera, ecc.), possono essere eventualmente inseriti (e rimossi in ogni momento) nella lista di esclusione con il menù contestuale (tasto destro del mouse). Dopo premi il pulsante Scarica gli aggiornamenti. Durante il download, ogni file completato sarà contrassegnato con una spunta verde.

Se prima vuoi ottenere maggiori informazioni sui nuovi aggiornamenti, premi il pulsante Leggi le novità online oppure visita il forum di supporto all'indirizzo http://www.net-integration.net/cgi-bin/forums/ikonboard.cgi.


Rapporto bugs

Dovresti utilizzare il modulo per l'invio di un rapporto sui difetti del programma soltanto come ultima risorsa. Le cose da fare prima sono verificare di possedere l'ultima versione, leggere le FAQ e visitare il forum del supporto tecnico. Se niente di tutto questo ti ha aiutato a risolvere il problema, allora puoi compilare un rapporto.

La funzione Rapporto bugs è raggiungibile dalla sezione Su Internet tramite la barra degli strumenti collocata sul lato sinistro.

Rileggi le avvertenze e poi premi il pulsante Successivo in fondo alla pagina. Se è la prima volta che accedi a questa funzione, è necessario dapprima configurare la posta elettronica. Per farlo, usa il pulsante Configurazione posta e inserisci i tuoi parametri nella finestra di dialogo che apparirà. Se adoperi Outlook o Outlook Express puoi importare direttamente da lì i tuoi dati con il pulsante Importa da... e ti rimarrà da inserire soltanto la password.

Una volta configurata correttamente la posta premi OK e inizia a descrivere dettagliatamente il difetto. Puoi visualizzare in anteprima il rapporto creato automaticamente dal sistema, con il pulsante Rapporto generato dal sistema, e trascinare i file che desideri allegare nell'apposito spazio in basso. Quando hai concluso queste operazioni e verificato che tutto sia corretto, premi il pulsante Invia per spedire il tutto.

Trovi ulteriori opzioni relative al rapporto sui difetti del programma nella pagina Impostazioni.


Disdette

Se in passato hai sottoscritto qualche servizio pubblicitario e te ne sei pentito, se non sai come uscirne, potresti essere fortunato e trovare l'inserzionista compreso in questa lista. Con un doppio clic sull'indirizzo puoi o visitare il sito e cercarvi all'interno la pagina per cancellarti o inviare direttamente una disdetta per posta (puoi distinguere i due casi dal tipo di icona davanti all'indirizzo).

Puoi raggiungere quest'elenco scegliendo Disdette nella sezione Su Internet tramite la barra degli strumenti sulla sinistra.


Tritatutto di sicurezza

Il Tritatutto di Sicurezza è uno strumento progettato per sbarazzarsi definitivamente dei file, senza alcuna successiva possibilità di ripristino.

Puoi raggiungerlo scegliendo Tritatutto nella sezione Utilità tramite la barra degli strumenti sulla sinistra.

Il procedimento è semplice – trascina nella finestra i file prescelti da Esplora Risorse (oppure aggiungili con il tasto destro tramite il menù contestuale), seleziona il numero di frammenti in cui vuoi ridurli e clicca sul pulsante Tritura!

Anche le tracce d'uso dei programmi vengono tritate automaticamente con l'impostazione predefinita di 5 frammenti.

I primi 5 frammenti utilizzano un modello di bit predefinito che dovrebbe garantire l'impossibilità di un ripristino hardware. Le mpostazioni oltre i 5 frammenti impiegheranno un modello di bit casuale che cambia ogni pochi Bytes.
Nota bene: impostare un solo frammento non è sufficiente a spezzettare il file poichè le testine del disco rigido non insistono sulla stessa traccia per il 100% del tempo. Ci sono piccoli salti di pochi micron (µm) che consentono di ricostruire i dati sovrascritti. Ecco i motivi per cui è necessario impostare frammenti multipli e usare differenti modelli di bit.

Attenzione: Questo strumento è progettato per rimuovere file in maniera tale che non possano più essere ripristinati. Se lo utilizzi, sappilo!

Rinuncia: Ho testato nel miglior modo questo strumento, ma non posso garantire che i file resi inutilizzabili vengano distrutti definitivamente.


Svuota il cestino

Alcune vecchie versioni di Spybot-S&D purtroppo creavano delle chiavi di registro proprio mentre ne veniva verificata l'esistenza. Se hai usato Spybot-S&D dalla v0.9 alla v0.94 dovresti adoperare questo strumento.

Puoi raggiungere questa utilità scegliendo Svuota il cestino nella sezione Utilità tramite la barra sulla sinistra.

Prima di tutto premi il pulsante Controlla le chiavi. Ciò può richiedere un po' di tempo, ma a conclusione visualizzerà l'elenco completo delle chiavi di registro accidentalmente create. Fatto questo puoi eliminarle selezionando il pulsante Rimuovi le chiavi. Nell'elenco appaiono solamente le chiavi vuote (inutilizzate), quindi non aver alcun timore se una chiave accidentalmente creata in passato, ma attualmente in uso, sarà visualizzata e rimossa.

Non vi è alcuna necessità di avviare questo strumento più di una volta, semprechè tu non intenda installare ed avviare ancora vecchie versioni di Spybot-S&D (non si capirebbe il motivo per cui dovresti farlo).